Problème YAW sur CC3d

Modérateur : Dehas

Avatar du membre
Ciolouse
Bicopter
Messages : 45
Enregistré le : mer. 19 oct. 2016 11:43
Réputation : 0

Problème YAW sur CC3d

Message non lu par Ciolouse » mer. 9 nov. 2016 11:26

Salutations,

J'ai un problème de réglages, je penses, sur ma CC3D, lorsque je fais une commande YAW, a la fin de celle ci, mon drone sursaute, monte brusquement, les moteurs prennent bcp de tours pendant un cours instant, surtout quand la commande de YAW est "brutale", si je fais tourner sur lui même mon drone lentement, la problème est imperceptible.

Je suis complètement ignare en réglages sur ma CC3D, je penses que c'est un truc de PID ou je ne sais pas ....

Je suis en Mode 1, sur GCS 16.09-RC2, Attitude 55, Rate 220, Rate Yaw 220, et mode de vol Attitude.

Merci de vos réponses !



Avatar du membre
Ciolouse
Bicopter
Messages : 45
Enregistré le : mer. 19 oct. 2016 11:43
Réputation : 0

Re: Problème YAW sur CC3d

Message non lu par Ciolouse » sam. 12 nov. 2016 18:41

Aucune idée ? même l'ombre d'une petite, un indice, rien ?? :pleur4:



Avatar du membre
f5soh
Octocopter
Messages : 656
Enregistré le : mer. 19 févr. 2014 13:40
Réputation : 0

Re: Problème YAW sur CC3d

Message non lu par f5soh » sam. 12 nov. 2016 18:53

Pour tourner sur l'axe Yaw, deux moteurs (sur la diagonale) accélèrent, au moment où tu arrêtes l'action sur le manche de Yaw tu as deux moteurs qui sont encore à "haut régime" et le seul moyen pour contrer le mouvement est d'accélérer les deux autres moteurs sur l'autre diagonale. Un court instant tu as donc tous les moteurs accélérés et donc un sursaut.

Ce phénomène est d'autant plus visible si les Esc ne freinent pas : genre Simonk comparé à des Esc en BLHeli.


http://www.thingiverse.com/LaurentL/designs" onclick="window.open(this.href);return false;
http://www.librepilot.org" onclick="window.open(this.href);return false;

Avatar du membre
Ciolouse
Bicopter
Messages : 45
Enregistré le : mer. 19 oct. 2016 11:43
Réputation : 0

Re: Problème YAW sur CC3d

Message non lu par Ciolouse » lun. 14 nov. 2016 10:11

Merci beaucoup f5soh de ta réponse !

Effectivement je suis en Simonk ...
Faut donc que je passe an BLHeli pour atténuer ce problème, mince, cela ne m'arrange pas, les LED ne sont pas supportées par BLHeli avec mes ESC.

Des que j'assure un peux plus en immersion (je fais plus de vol a vue pour le moment), je passe en BLHeli !



Avatar du membre
f5soh
Octocopter
Messages : 656
Enregistré le : mer. 19 févr. 2014 13:40
Réputation : 0

Re: Problème YAW sur CC3d

Message non lu par f5soh » lun. 14 nov. 2016 10:32

Attention, certains Esc, bien que flashés en BLHeli ne peuvent pas freiner à cause de leur conception (c'est le cas de certains Emax 12A)

Une vidéo qui montre bien la différence avec le damping light:

https://www.youtube.com/watch?v=QiAJkl_Opxk[/BBvideo]


http://www.thingiverse.com/LaurentL/designs" onclick="window.open(this.href);return false;
http://www.librepilot.org" onclick="window.open(this.href);return false;

Répondre

Retourner vers « Cartes et modules Openpilot. »