F3 EVO Flight fonctionne pas

Modérateur : Dehas

Avatar du membre
fjaffre
Tricopter
Messages : 87
Enregistré le : mar. 4 oct. 2016 18:33
Réputation : 0

F3 EVO Flight fonctionne pas

Message non lu par fjaffre » mer. 7 déc. 2016 23:35

Salut a tous, j'ai acheté cette carte : http://www.ebay.fr/itm/131925758467?_tr ... EBIDX%3AIT" onclick="window.open(this.href);return false;

Quand je branche ma batterie mes 4 moteurs démarrent de suite pratiquement a fond :|
Je me connecte a Cleanflight sans problème, tout semble fonctionner, le RX est ok...
Donc mes 4 moteurs démarrent alors que la carte est desarmée !
Je tente de la flasher et impossible... j'ai le message : No response from bootloader, programming: FAILED
J'ai ce message quand je ne fais pas le pont sur les 2 contacts du Bootloader, quand je fais le pont j'ai un problème de port

voici ma carte en photo

Image

Pouvez vous m'aider :155:



Avatar du membre
Dehas
Administrateur du site
Messages : 13275
Enregistré le : ven. 3 juin 2011 12:50
Réputation : 5
Localisation : Saint Dié des Vosges
Genre :
Contact :

Re: F3 EVO Flight fonctionne pas

Message non lu par Dehas » jeu. 8 déc. 2016 08:57

Sur ton lien, le vendeur met le lien vers la notice, prends là et lis bien, il te faut le logiciel Zadig pour la mettre a jour !!



Avatar du membre
fjaffre
Tricopter
Messages : 87
Enregistré le : mar. 4 oct. 2016 18:33
Réputation : 0

Re: F3 EVO Flight fonctionne pas

Message non lu par fjaffre » jeu. 8 déc. 2016 09:04

mon soucis s'est que le lien ne s'ouvre pas chez moi, ça tourne et ne s'ouvre pas.



Avatar du membre
Papi78
Pilote toutes catégories
Messages : 2976
Enregistré le : ven. 3 mai 2013 12:13
Réputation : 0
Localisation : 39 et 78 à mi temps

Re: F3 EVO Flight fonctionne pas

Message non lu par Papi78 » jeu. 8 déc. 2016 09:24

Hello
Va dans la CLI et tape :

Code : Tout sélectionner

set motor_pwm_rate = 32000
save
Sinon pour flasher, suis ces instructions:
LuluTchab a écrit :Alors tu n'es pas obligé de souder ou de faire un pont sur les 2 pad "boot". Voilà comment j'ai fait moi :
  1. Connecter la FC au PC. Un port COM est "créé" pour la FC
  2. Ouvrir BetaFlight Configurator
  3. Sélectionner le bon port COM
  4. Aller dans "Firmware Flasher"
  5. Sélectionner SPRACINGF3EVO et le dernier firmware de BetaFlight
  6. Cocher "Full Chip Erase" et sélectionner "Manual Baud Rate" à 256000
  7. Cliquer en bas à droite sur "Load Firmware [Online]"
  8. Une fois le firmware téléchargé, cliquer sur "Flash Firmware"
  9. Là, la FC va reboot pour passer en mode bootloader pour le flashage. MAIS comme Windows n'a pas le driver, il ne pourra pas communiquer avec la FC. C'est là que Zadigintervient.
    Il faut suivre les infos de la vidéo à partir de 4:06 et jusqu'à 5:06 (pendant une minute quoi).
    https://www.youtube.com/watch?v=cCgrKOVxnWQ[/BBvideo]
  10. Une fois le driver mis à jour pour le "STM32 Bootloader", ça devrait être bon.
  11. Déconnecter la FC de l'ordi
  12. Reconnecter la FC à l'ordi
  13. Sélectionner le bon port COM dans BetaFlight Configurator
  14. Aller dans "Firmware Flasher"
  15. Sélectionner SPRACINGF3EVO et le dernier firmware de BetaFlight
  16. Cocher "Full Chip Erase" et sélectionner "Manual Baud Rate" à 256000
  17. Cliquer en bas à droite sur "Load Firmware [Online]"
  18. Une fois le firmware téléchargé, cliquer sur "Flash Firmware"
  19. La FC va à nouveau rebooter et là, comme elle aura le driver pour le "STM32 Bootloader", ça devrait passer tout seul.
J'espère que ça pourra aider :D


Quand tu te sens en situation d'échec, souviens toi que le grand chêne a lui aussi été un gland !

Avatar du membre
fjaffre
Tricopter
Messages : 87
Enregistré le : mar. 4 oct. 2016 18:33
Réputation : 0

Re: F3 EVO Flight fonctionne pas

Message non lu par fjaffre » jeu. 8 déc. 2016 09:26

Le lien s'est ouvert, je bloque a l'etape 3 lorsqu'il est indiqué de cliquer sur flash j'obtiens une erreur port. :85:



Avatar du membre
Papi78
Pilote toutes catégories
Messages : 2976
Enregistré le : ven. 3 mai 2013 12:13
Réputation : 0
Localisation : 39 et 78 à mi temps

Re: F3 EVO Flight fonctionne pas

Message non lu par Papi78 » jeu. 8 déc. 2016 09:37

Tu as modifié le motor_pwm_rate? Commence par là
A l'étape 3 on en est pas encore a cliquer sur flash....


Quand tu te sens en situation d'échec, souviens toi que le grand chêne a lui aussi été un gland !

Avatar du membre
fjaffre
Tricopter
Messages : 87
Enregistré le : mar. 4 oct. 2016 18:33
Réputation : 0

Re: F3 EVO Flight fonctionne pas

Message non lu par fjaffre » jeu. 8 déc. 2016 09:52

3. Click “Flash Firmware” and wait the ST DFU DRIVER Automatic installation. It’s successfully installed when you see the DFU port on the Up right corner.

Ensuite j'ai eu ERASE de marqué et bloqué la dessus...



Avatar du membre
Papi78
Pilote toutes catégories
Messages : 2976
Enregistré le : ven. 3 mai 2013 12:13
Réputation : 0
Localisation : 39 et 78 à mi temps

Re: F3 EVO Flight fonctionne pas

Message non lu par Papi78 » jeu. 8 déc. 2016 10:00

Avant d'essayer de flasher et afin de vérifier si ta carte fonctionne correctement, as-tu essayer la modif CLI?
La procédure ci-dessus a fonctionné pour tout le monde, donc soit tu as zappé quelque chose soit ta carte est HS.
Au cas ou tu refais la procédure en strappant les pads du bootloader


Quand tu te sens en situation d'échec, souviens toi que le grand chêne a lui aussi été un gland !

Avatar du membre
fjaffre
Tricopter
Messages : 87
Enregistré le : mar. 4 oct. 2016 18:33
Réputation : 0

Re: F3 EVO Flight fonctionne pas

Message non lu par fjaffre » jeu. 8 déc. 2016 10:02

Le probleme aussi (j'avais pas le son d'allumé), le bruit quand on branche un USB je l'ai en permanence quand je branche ma carte avec le shunt bootloader et il trouve pas le driver. J'ai cherché en ligne et trouve pas. Voila pourquoi je peux pas flasher.



Avatar du membre
fjaffre
Tricopter
Messages : 87
Enregistré le : mar. 4 oct. 2016 18:33
Réputation : 0

Re: F3 EVO Flight fonctionne pas

Message non lu par fjaffre » jeu. 8 déc. 2016 10:03

et dans Zadig le st32 bootloader apparaît et disparaît sans arret



Avatar du membre
fjaffre
Tricopter
Messages : 87
Enregistré le : mar. 4 oct. 2016 18:33
Réputation : 0

Re: F3 EVO Flight fonctionne pas

Message non lu par fjaffre » jeu. 8 déc. 2016 10:07

Je n'ai plus acces a ma carte dans cleanflight, j'ai bien l'impression que s'est le même cinéma que ma carte miniOSD qui voulais rien savoir.



Avatar du membre
Papi78
Pilote toutes catégories
Messages : 2976
Enregistré le : ven. 3 mai 2013 12:13
Réputation : 0
Localisation : 39 et 78 à mi temps

Re: F3 EVO Flight fonctionne pas

Message non lu par Papi78 » jeu. 8 déc. 2016 10:09

Il faut suivre les instructions en français ci-dessus à la lettre...
La première fois que tu vas essayer de flasher il va y avoir un message d'erreur mais le port de la carte est ouvert, ce qui va permettre à Zadig de le trouver et d'installer le bon driver. Donc tu t'arrêtes pas en cours mais tu vas jusqu'au bout.


Quand tu te sens en situation d'échec, souviens toi que le grand chêne a lui aussi été un gland !

Avatar du membre
fjaffre
Tricopter
Messages : 87
Enregistré le : mar. 4 oct. 2016 18:33
Réputation : 0

Re: F3 EVO Flight fonctionne pas

Message non lu par fjaffre » jeu. 8 déc. 2016 10:15

pour avoir accès au bootloader dans zadig il me faut le shunt et le driver bip sans arrêt comme ci on branchait/débranchait sans arret



Avatar du membre
Papi78
Pilote toutes catégories
Messages : 2976
Enregistré le : ven. 3 mai 2013 12:13
Réputation : 0
Localisation : 39 et 78 à mi temps

Re: F3 EVO Flight fonctionne pas

Message non lu par Papi78 » jeu. 8 déc. 2016 10:17

Non, pas besoin du shunt normalement


Quand tu te sens en situation d'échec, souviens toi que le grand chêne a lui aussi été un gland !

Avatar du membre
fjaffre
Tricopter
Messages : 87
Enregistré le : mar. 4 oct. 2016 18:33
Réputation : 0

Re: F3 EVO Flight fonctionne pas

Message non lu par fjaffre » jeu. 8 déc. 2016 10:20

donc sans le shunt dans zadig je vois stm32 virtual com port mais plus stm32 bootloader



Avatar du membre
Papi78
Pilote toutes catégories
Messages : 2976
Enregistré le : ven. 3 mai 2013 12:13
Réputation : 0
Localisation : 39 et 78 à mi temps

Re: F3 EVO Flight fonctionne pas

Message non lu par Papi78 » jeu. 8 déc. 2016 10:24

Tu as recommencé la procédure dès le début, en ouvrant Zadig qu'une fois la première tentative effectuée?


Quand tu te sens en situation d'échec, souviens toi que le grand chêne a lui aussi été un gland !

Avatar du membre
fjaffre
Tricopter
Messages : 87
Enregistré le : mar. 4 oct. 2016 18:33
Réputation : 0

Re: F3 EVO Flight fonctionne pas

Message non lu par fjaffre » jeu. 8 déc. 2016 10:27

Je ne vois pas quoi faire dans zadig vu que je n'ai pas acces a STM32 bootloader mais stm32 virtual com port



Avatar du membre
fjaffre
Tricopter
Messages : 87
Enregistré le : mar. 4 oct. 2016 18:33
Réputation : 0

Re: F3 EVO Flight fonctionne pas

Message non lu par fjaffre » jeu. 8 déc. 2016 11:13

Dans zadig STM32 Bootloader avec le driver STTub30 ne bip plus et reste stable mais je n'ai accès a rien. Donc dans zadig, je clic sur STM32 bootloader, ensuite sur replace driver, et la le périphérique se met a bipper sans arrêt comme si on branchait/débranchait un usb.

Je pense que le microdrone va volé, mais pas comme il se doit.



Avatar du membre
fjaffre
Tricopter
Messages : 87
Enregistré le : mar. 4 oct. 2016 18:33
Réputation : 0

Re: F3 EVO Flight fonctionne pas

Message non lu par fjaffre » jeu. 8 déc. 2016 11:27

Je parviens a avoir accès aux paramétrés de ma SP Racing F3, mais plus a ma SP Racing F3 EVO. Cela veut tout dire !



Avatar du membre
Papi78
Pilote toutes catégories
Messages : 2976
Enregistré le : ven. 3 mai 2013 12:13
Réputation : 0
Localisation : 39 et 78 à mi temps

Re: F3 EVO Flight fonctionne pas

Message non lu par Papi78 » jeu. 8 déc. 2016 11:39

Y'a un progrès il a trouvé STM32 bootloader....
En face Sttub30, tu as bien choisis WINUSB ?


Quand tu te sens en situation d'échec, souviens toi que le grand chêne a lui aussi été un gland !

Avatar du membre
fjaffre
Tricopter
Messages : 87
Enregistré le : mar. 4 oct. 2016 18:33
Réputation : 0

Re: F3 EVO Flight fonctionne pas

Message non lu par fjaffre » jeu. 8 déc. 2016 11:41

oui quand je choisi winusb ben ça va plus



Avatar du membre
Papi78
Pilote toutes catégories
Messages : 2976
Enregistré le : ven. 3 mai 2013 12:13
Réputation : 0
Localisation : 39 et 78 à mi temps

Re: F3 EVO Flight fonctionne pas

Message non lu par Papi78 » jeu. 8 déc. 2016 11:42

Et quand tu flashes sans shunt, il ne faut pas cocher "No reboot sequence"


Quand tu te sens en situation d'échec, souviens toi que le grand chêne a lui aussi été un gland !

Avatar du membre
fjaffre
Tricopter
Messages : 87
Enregistré le : mar. 4 oct. 2016 18:33
Réputation : 0

Re: F3 EVO Flight fonctionne pas

Message non lu par fjaffre » jeu. 8 déc. 2016 11:51

Par contre on est ok que sans shunt je n'ai plus le Bootloader, mais stm32 virtual com port



Avatar du membre
fjaffre
Tricopter
Messages : 87
Enregistré le : mar. 4 oct. 2016 18:33
Réputation : 0

Re: F3 EVO Flight fonctionne pas

Message non lu par fjaffre » jeu. 8 déc. 2016 11:52

Mais je n'ai plus accès a la carte avec cleanflight de toute façon, je pense pas a un problème de driver vu que ma SP RACING F3 elle se connecte.



Avatar du membre
fjaffre
Tricopter
Messages : 87
Enregistré le : mar. 4 oct. 2016 18:33
Réputation : 0

Re: F3 EVO Flight fonctionne pas

Message non lu par fjaffre » jeu. 8 déc. 2016 11:54

par contre avec le shunt j'ai acces avec Dfuse demo



Répondre

Retourner vers « Carte Naze32 et dérivés »