Bienvenue sur Multi Rotor Fans Club. Cliquer ici pour vous enregistrer
ou ici pour vous connecter


  • Annonce

Bonjour a tous.
Un petit changement sur l'adresse du forum qui a quand même son importance, surtout en terme de sécurité, c'est que nous passons en https, donc en connexion sécurisé.
Il vous suffit de modifier votre favori et/ou marque page et de regarder si tout fonctionne bien.
Si vous avez des erreurs, il vous suffit de définir le permissions.
Je vous recommande de le faire, car vous risquez de vous reconnecter a chaque session.
Voila, j’espère que cela vous conviens, j'essaye de faire le maximum pour que vous soyez en sécurité.
Dehas



Multiwii 2.3 et OSD

Modérateur: Dehas

Multiwii 2.3 et OSD

Message non lupar philchar » Dim 18 Juin 2017 18:54

Bonjour
J'ai un quadri 450 avec une carte Crius AIOP V2 flashée avec Multiwii 2.3. Le GPS est sur le port série 2. Tout cela marche très bien.
J'essaye de brancher un OSD RCTimer mini-OSD sur le port série 3, je suis sur ce problème depuis 2 semaine sans réussir a les faire causer.
J'ai brancher un oscilloscope sur la sortie port serie 3 de la Multiwii et je n'ai qu'un signal a +5V sans aucune modulation.
Le config me semble OK : telemetrie activée sur port 3, fréquence a 57600 bauds.
Quelqu'un aurait il une idée, ou une config équivalente a ce que je cherche a faire ?

Cdlt
Avatar de l’utilisateur
philchar
 
Messages: 8
Enregistré le: Dim 18 Juin 2017 12:29

Re: Multiwii 2.3 et OSD

Message non lupar opossome64 » Lun 19 Juin 2017 08:49

Yop !

Ce n'est pas la télémétrie mais le MSP qu'il faut activé sur l'UART où tu connecte ton OSD .

Bon courage !
- SpeedRacer 210 - RS2205 - XM20A - SP3 Betaflight
- QX90
- Optic6 2.4Ghz FRSky
- BaseSD + VRX + faceplate mod
Chaine Youtube
Avatar de l’utilisateur
opossome64
Pilote toutes catégories
Absent
 
Messages: 903
Enregistré le: Jeu 17 Oct 2013 18:22
Localisation: Plus au sud ...
    Voir la position géographique du membre

Re: Multiwii 2.3 et OSD

Message non lupar Dehas » Lun 19 Juin 2017 09:26

Tu as paramétré comment ton osd ??
Avatar de l’utilisateur
Dehas
Administrateur du site
Absent
Souscripteur:  Souscripteur:
 
Messages: 13133
Enregistré le: Ven 3 Juin 2011 12:50
Localisation: Saint Dié des Vosges
    Voir la position géographique du membre

Re: Multiwii 2.3 et OSD

Message non lupar philchar » Mar 20 Juin 2017 22:27

Justement c'est un peut mon problème je ne trouve pas comment activer le MSP dans le config.h
Le seul paramètre que j'ai c'est le baud rate pour le serial 3
Je ne pense pas que le problème soit coté OSD puisque je n'ai aucun signal (contrôlé a l'oscilloscope) sur la sortie TX de la Crius, la liaison min étant avec 1 seul fil (TX sur RX) je suppose que la Crius doit envoyer un signal dés la fin de l'initialisation (sans contrôle de flux)

Qu'en penses tu ?
Avatar de l’utilisateur
philchar
 
Messages: 8
Enregistré le: Dim 18 Juin 2017 12:29

Re: Multiwii 2.3 et OSD

Message non lupar Dehas » Mar 20 Juin 2017 22:59

Vas voir là: https://oscarliang.com/program-minimosd ... tdi-cable/
Apparemment, l'osd se branche sur l'uart1
Avatar de l’utilisateur
Dehas
Administrateur du site
Absent
Souscripteur:  Souscripteur:
 
Messages: 13133
Enregistré le: Ven 3 Juin 2011 12:50
Localisation: Saint Dié des Vosges
    Voir la position géographique du membre

Re: Multiwii 2.3 et OSD

Message non lupar philchar » Jeu 22 Juin 2017 06:56

J'ai teste pas de choses mais ce n'est pas concluant.
Pourtant il semble que ce type soit classique.
Quelqu'un aurait il un OSD branché sur une AIOP sous Multiwwi
Avatar de l’utilisateur
philchar
 
Messages: 8
Enregistré le: Dim 18 Juin 2017 12:29

Re: Multiwii 2.3 et OSD

Message non lupar Dehas » Jeu 22 Juin 2017 09:04

Tu n'as pas répondu a ma question plus haut, tu as paramétré comment ton osd ?
Un lien ou tu l'as acheté ?
Avatar de l’utilisateur
Dehas
Administrateur du site
Absent
Souscripteur:  Souscripteur:
 
Messages: 13133
Enregistré le: Ven 3 Juin 2011 12:50
Localisation: Saint Dié des Vosges
    Voir la position géographique du membre

Re: Multiwii 2.3 et OSD

Message non lupar philchar » Jeu 22 Juin 2017 22:36

J'ai acheté l'OSD sur internet et je l'ai flashé avec un package contenant une partie compilable et une partie pour le GUI : Arducam OSD config 2120.
Il n'y a pas grand chose concernant la config du protocole série, c'est plutôt la config de l'affichage des données sur la video
Il y a une subtilité sur cette partie ?
Avatar de l’utilisateur
philchar
 
Messages: 8
Enregistré le: Dim 18 Juin 2017 12:29

Re: Multiwii 2.3 et OSD

Message non lupar opossome64 » Ven 23 Juin 2017 18:26

Yop !

Ben t'as pas le bon firmware , Arducam c'est pour de l'APM et y'a longtemps ^^

Regarde par ici --> MW OSD

Bon courage !
- SpeedRacer 210 - RS2205 - XM20A - SP3 Betaflight
- QX90
- Optic6 2.4Ghz FRSky
- BaseSD + VRX + faceplate mod
Chaine Youtube
Avatar de l’utilisateur
opossome64
Pilote toutes catégories
Absent
 
Messages: 903
Enregistré le: Jeu 17 Oct 2013 18:22
Localisation: Plus au sud ...
    Voir la position géographique du membre

Re: Multiwii 2.3 et OSD

Message non lupar philchar » Ven 23 Juin 2017 22:45

J'essaye demain avec MWOSD pour le coté OSD
Pour la partie multiwii que faut il faire (decommenter) dans le config.h ?
Avatar de l’utilisateur
philchar
 
Messages: 8
Enregistré le: Dim 18 Juin 2017 12:29

Re: Multiwii 2.3 et OSD

Message non lupar opossome64 » Sam 24 Juin 2017 08:58

Yop !

Dans mon souvenir , j'ai pas touché à Multiwii depuis une paye, la faute à Angusfly :33: , rien du tout , juste ne pas utiliser un UART déjà attribué à autre chose (GPS , Bluetooth ...) .

Par contre dans le config.h de MWOSD , bien dé-commenter sa version de Multiwii , sa carte miminosd , vitesse du port com , etc ...

++
- SpeedRacer 210 - RS2205 - XM20A - SP3 Betaflight
- QX90
- Optic6 2.4Ghz FRSky
- BaseSD + VRX + faceplate mod
Chaine Youtube
Avatar de l’utilisateur
opossome64
Pilote toutes catégories
Absent
 
Messages: 903
Enregistré le: Jeu 17 Oct 2013 18:22
Localisation: Plus au sud ...
    Voir la position géographique du membre

Re: Multiwii 2.3 et OSD

Message non lupar philchar » Sam 24 Juin 2017 15:39

Grand jour le 24 juin, ça marche

OSD flashé avec le lien de Opossome64 (configuration de la vitesse, du type de carte, ...)
Téléchargement de la police de caractère fournie avec le package telechargé (font bold)
Raccordement du RX et du TX croisés
Activation de la telemetrie et réglage de la vitesse dans Multiwii 2.3

C'est pas immédiat quand même, merci a tous les 2 pour votre aide

Bon vols

Philippe
Avatar de l’utilisateur
philchar
 
Messages: 8
Enregistré le: Dim 18 Juin 2017 12:29

Re: Multiwii 2.3 et OSD

Message non lupar opossome64 » Sam 24 Juin 2017 17:57

Derien , et surtout bon vol !
- SpeedRacer 210 - RS2205 - XM20A - SP3 Betaflight
- QX90
- Optic6 2.4Ghz FRSky
- BaseSD + VRX + faceplate mod
Chaine Youtube
Avatar de l’utilisateur
opossome64
Pilote toutes catégories
Absent
 
Messages: 903
Enregistré le: Jeu 17 Oct 2013 18:22
Localisation: Plus au sud ...
    Voir la position géographique du membre


Retourner vers Cartes a base de Multiwii

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité