J'ai aussi craqué et je vais avoir besoin de votre aide !

Modérateur : Dehas

Avatar du membre
waldi57200
Octocopter
Messages : 754
Enregistré le : jeu. 1 nov. 2012 14:45
Réputation : 0

Re: J'ai aussi craqué et je vais avoir besoin de votre aide

Message non lu par waldi57200 » lun. 17 oct. 2016 09:11

bruno a écrit :Ha ok, j'avais pas compris ton passage sous S3D.

Dans le menu Tools > Option
Onglet Machine:
En "Tollhead offsets" pour tes 2 buses, ton offsets en X et Y est bon ?
Bonjour Bruno,

oui le tollhead offset et ok , j'ai mis les donné constructeur mais je viens de voir un truc, je m'explique.
Il y a 2 façon de modifié les paramètres machine : via préférences ou via édit processing onglet G-code et update machine setting. Ce dernier point je l'ai décoché comme sur ton tuto.
Mais le hic s'est que je viens de remarquer en chargeant des profils enregistré d'imprimantes que cette option est coché avec les même paramètres que dans préférences onglet machine.
Autre point s'est que mes données constructeurs me disent de mettre extrudeur 1 axe X 16 et extrudeur 2 axe X -16 par contre sous S3D l'extruder de référence donc le 1
reste à 0 et le second à une valeur donc pour moi cela doit être 32 (distance entre les 2).

Je vais continuer à chercher et fouiller pour voir si çà me conforte dans mon analyse puis je testerai.

Tu en penses quoi de mon raisonnement si tu as compris ce que je viens d'écrire :hehe:

@+


Penguin FPV

FrSky Taranis +

bruno
Pilote toutes catégories
Messages : 1803
Enregistré le : mar. 15 avr. 2014 11:39
Réputation : 0
Localisation : Créteil (94)

Re: J'ai aussi craqué et je vais avoir besoin de votre aide

Message non lu par bruno » lun. 17 oct. 2016 09:31

Je suppose que dans l'onglet Machine:
T0 est l'extrudeur de gauche par exemple et que celui ci doit être 0
T1 est l'extrudeur de droit et par contre devrait avoir un offset

A mon sens, en fait y-a plusieurs solution :
Firmawer via :
#define EXTRUDER_OFFSET_X
#define EXTRUDER_OFFSET_Y

GCode via une commande M218 pour que extruder (a placer en startGCode avec tes bonnes valeurs):
M218 X0 Y0 T0
M218 X0 Y-16 T1
Image
Toutefois comme tu peux le voir M218 n'est pris en compte que dans Marlin.



Avatar du membre
waldi57200
Octocopter
Messages : 754
Enregistré le : jeu. 1 nov. 2012 14:45
Réputation : 0

Re: J'ai aussi craqué et je vais avoir besoin de votre aide

Message non lu par waldi57200 » lun. 17 oct. 2016 10:11

bruno a écrit :Je suppose que dans l'onglet Machine:
T0 est l'extrudeur de gauche par exemple et que celui ci doit être 0
T1 est l'extrudeur de droit et par contre devrait avoir un offset
Chez moi oui mais certaines config enregistré s'est l'inverse pourquoi ?????

bruno a écrit :
A mon sens, en fait y-a plusieurs solution :
Firmawer via :
#define EXTRUDER_OFFSET_X
#define EXTRUDER_OFFSET_Y

GCode via une commande M218 pour que extruder (a placer en startGCode avec tes bonnes valeurs):
M218 X0 Y0 T0
M218 X0 Y-16 T1
[ Image ]
Toutefois comme tu peux le voir M218 n'est pris en compte que dans Marlin.
Alors honte à moi mais je ne suis jamais allé voir dans le firmware comment çà se goupille. J'ai bien essayé en installant arduino 1.6 mais jamais réussi à connecter ma carte et se n'ai pas faute d'avoir voulu essayer.
J'ai même été tenter de mettre à jour Marlin qui chez moi est en 1.02 ou un truc du genre mais vu que je suis en 2 estrudeurs je ne savais pas si çà marchait.


@+


Penguin FPV

FrSky Taranis +

bruno
Pilote toutes catégories
Messages : 1803
Enregistré le : mar. 15 avr. 2014 11:39
Réputation : 0
Localisation : Créteil (94)

Re: J'ai aussi craqué et je vais avoir besoin de votre aide

Message non lu par bruno » lun. 17 oct. 2016 10:53

Quel est ta carte déjà ?

En Arduino 1.6.x tu dois activer le bon JSON vie le menu Outils > Type de Carte > Gestionnaire de carte.
Par exemple avec une Melzi : http://multi-rotor-fans-club.com/viewto ... 65&t=19007" onclick="window.open(this.href);return false;

Perso sur ma future CoreXY avec Ramp 1.4 je prendrais le Marlin RC7 (https://github.com/MarlinFirmware/Marlin" onclick="window.open(this.href);return false;). Car ce dernier inclus la commande M600 (mise ne pause) qui m’intéresse.

Si tu fait l'update de ton firmware, dans Marlin tu dit tous configurer regarde ici : http://solidutopia.com/fr/configurer-le ... re-marlin/" onclick="window.open(this.href);return false; c'est une bonne base. Mais attention c'est pas tjrs simple avec certaines cartes.



bruno
Pilote toutes catégories
Messages : 1803
Enregistré le : mar. 15 avr. 2014 11:39
Réputation : 0
Localisation : Créteil (94)

Re: J'ai aussi craqué et je vais avoir besoin de votre aide

Message non lu par bruno » lun. 17 oct. 2016 11:20

Je viens aussi de retrouver un liens vers une liste des cartes : https://github.com/arduino/Arduino/wiki ... pport-urls" onclick="window.open(this.href);return false;



Avatar du membre
waldi57200
Octocopter
Messages : 754
Enregistré le : jeu. 1 nov. 2012 14:45
Réputation : 0

Re: J'ai aussi craqué et je vais avoir besoin de votre aide

Message non lu par waldi57200 » lun. 17 oct. 2016 11:51

Ma carte est une GT2560 avec ramps 1.4 intégré mais en sélectionnant Atmega 2560 çà marche pas.

En tout cas vais étudier tout tes liens avec attention.

Merci Bruno ;)

@+


Penguin FPV

FrSky Taranis +

bruno
Pilote toutes catégories
Messages : 1803
Enregistré le : mar. 15 avr. 2014 11:39
Réputation : 0
Localisation : Créteil (94)

Re: J'ai aussi craqué et je vais avoir besoin de votre aide

Message non lu par bruno » lun. 17 oct. 2016 12:01

Le driver FTDI est OK, elle apparait bien dans le gestionnaire de périphérique ? Je suppose que oui puisque imprime avec.
Avec un Arduino 1.0.x tu dois choisir Mega 2560 et le bon port.
Avec un Arduino 1.6.x c'est Arduino mega ADK (je crois à vérifier).

Mais avant quoi que ce soit fait déjà le test avec le GCode M218.



Avatar du membre
waldi57200
Octocopter
Messages : 754
Enregistré le : jeu. 1 nov. 2012 14:45
Réputation : 0

Re: J'ai aussi craqué et je vais avoir besoin de votre aide

Message non lu par waldi57200 » mar. 18 oct. 2016 13:46

Salut,

Bon j'ai fait le c.., je crois :rouge:

J'ai essayer de faire reconnaitre ma carte avec arduino hier dans l'après midi.
Quand j'ai éteint le tout s'était ok et aujourd'hui en allumant mon imprimante j'ai :

Image


:155: :155: :155:


Penguin FPV

FrSky Taranis +

bruno
Pilote toutes catégories
Messages : 1803
Enregistré le : mar. 15 avr. 2014 11:39
Réputation : 0
Localisation : Créteil (94)

Re: J'ai aussi craqué et je vais avoir besoin de votre aide

Message non lu par bruno » mar. 18 oct. 2016 14:37

Regarde dans ton Marlin.
Il semble que pout toi ce soit #define REPRAP_DISCOUNT_SMART_CONTROLLER”
Il est possible également que tu doives utiliser la librairie u8Glib.



Avatar du membre
waldi57200
Octocopter
Messages : 754
Enregistré le : jeu. 1 nov. 2012 14:45
Réputation : 0

Re: J'ai aussi craqué et je vais avoir besoin de votre aide

Message non lu par waldi57200 » mar. 18 oct. 2016 14:46

bruno a écrit :Regarde dans ton Marlin.
Il semble que pout toi ce soit #define REPRAP_DISCOUNT_SMART_CONTROLLER”
Il est possible également que tu doives utiliser la librairie u8Glib.
Euh là, je suis largué.
J'ai enfin réussi à ouvrir le fichier "config h"

j'ai trouvé cà:

//#define U8GLIB_SSD1306
#define U8GLIB_SH1106
#endif

mais pas le #define REPRAP_DISCOUNT_SMART_CONTROLLER

et je dois faire quoi exactement avec ces commandes ?

Dans "conditionnals h"j'ai trouvé çà :

#if ENABLED(REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER)
#define DOGLCD
#define U8GLIB_ST7920
#define REPRAP_DISCOUNT_SMART_CONTROLLER
#endif


Penguin FPV

FrSky Taranis +

bruno
Pilote toutes catégories
Messages : 1803
Enregistré le : mar. 15 avr. 2014 11:39
Réputation : 0
Localisation : Créteil (94)

Re: J'ai aussi craqué et je vais avoir besoin de votre aide

Message non lu par bruno » mar. 18 oct. 2016 15:20

c'est quoi ton écran ? Un LCD 2004 ?



bruno
Pilote toutes catégories
Messages : 1803
Enregistré le : mar. 15 avr. 2014 11:39
Réputation : 0
Localisation : Créteil (94)

Re: J'ai aussi craqué et je vais avoir besoin de votre aide

Message non lu par bruno » mar. 18 oct. 2016 15:23

Regarde ici : https://www.youtube.com/watch?v=MZUKLVXI3Js" onclick="window.open(this.href);return false;



Avatar du membre
waldi57200
Octocopter
Messages : 754
Enregistré le : jeu. 1 nov. 2012 14:45
Réputation : 0

Re: J'ai aussi craqué et je vais avoir besoin de votre aide

Message non lu par waldi57200 » mar. 18 oct. 2016 15:30

bruno a écrit :c'est quoi ton écran ? Un LCD 2004 ?
Oui merci pour le lien de la vidéo ;)

je te laisse tranquille, j'ai des soucis avec les vendeurs de la maison? le notaire vient de m'appeler.

Donc standby

@+


Penguin FPV

FrSky Taranis +

bruno
Pilote toutes catégories
Messages : 1803
Enregistré le : mar. 15 avr. 2014 11:39
Réputation : 0
Localisation : Créteil (94)

Re: J'ai aussi craqué et je vais avoir besoin de votre aide

Message non lu par bruno » mar. 18 oct. 2016 15:32

de rien ... tu me dira si ça marche.
Au besoin tu me fera suivre ton Marlin car nous n'avons pas le même et je regarderais pour essayer de t'aider.

Bonne chance avec tes autres Pb.



bruno
Pilote toutes catégories
Messages : 1803
Enregistré le : mar. 15 avr. 2014 11:39
Réputation : 0
Localisation : Créteil (94)

Re: J'ai aussi craqué et je vais avoir besoin de votre aide

Message non lu par bruno » mar. 18 oct. 2016 15:52

Tu pourra aussi regarder ici : https://georgeroblesjr.wordpress.com/20 ... -i3-pro-b/" onclick="window.open(this.href);return false;



Avatar du membre
waldi57200
Octocopter
Messages : 754
Enregistré le : jeu. 1 nov. 2012 14:45
Réputation : 0

Re: J'ai aussi craqué et je vais avoir besoin de votre aide

Message non lu par waldi57200 » sam. 29 oct. 2016 13:13

Salut à tous,

Reprise de mes réglages sur mon imprimante avec comme objectif, comprendre un peu marlin, Simplify 3D et le réglage de la double extrusion.

Après pas mal de lecture, l'appui bienveillants autant moral que technique de Bruno et d'un membre sur un groupe Facebook j'ai pas mal avancé.

Première étape, trouver le marlin de mon Imprimante qui m'éviterai une configuration totale de ce dernier. J'ai trouvé ce firmware par le biais d'un personne sur le net qui a la même imprimante [yahoo.gif]

En résumé, il faut que j'utilise Arduino 1.O.1 et non la dernière sinon çà ne marche pas. S'est pour cela que je n'arrivais pas à faire reconnaitre ma carte. Ne me demandez pas pourquoi :-/

Après avoir réinjecté le firmware d'origine s'est à nouveau ok (affichage LCD). Une fois cela de fait j'ai repris le wiki reprap et repris toutes les calibration.

Une fois cela fait, je me suis penché sur le soucis d'offset de buses (impressions décalées). Donc sous S3D, edit processing onglet Gcode il y a une ligne toolhead offset s'est celle ci que je modifiais mais sans que celà ne change au niveau de mes impressions. En fait dans cet onglet Gcode sur la partie de gauche il y a différentes options à cocher. L'une d'elle n'est pas coché " apply toolhead offset...." ben il faut la cocher pour appliquer les valeurs rentrées dans Toolhead offset à droite.
J'ai donc fait ceci mais dans la prévisualisation les 2 parties imprimés sont décalées. J'ai tout de même lancé l'impression mais sans succès.

J'ai donc décidé une seconde méthode conseillé sur mon groupe d'entraide qui est de modifié directement le marlin. J'ai donc mis les valeurs d'offset que j'avais sous Repetier ( valeurs constructeurs) et la bingo [yahoo.gif] [yahoo.gif]

J'ai donc lancé l'impression du fameux 3Dbenchy (petit bateau). Le résultat est pas mal mais y a à affiner les réglages. J'ai eu aussi la coque de protection autour le l'impression qui s'est décolé sur une partie et çà m'a foutu un peu la m...e :92:

J'espère voir enfin le bout du tunnel et prendre du plaisir à imprimer plus souvent que de régler :hehe:

Les photos de mon 3Dbenchy:

Image

Image

Image

Image

Image

Image


J'attends vos commentaires et conseils ;)

@+


Penguin FPV

FrSky Taranis +

bruno
Pilote toutes catégories
Messages : 1803
Enregistré le : mar. 15 avr. 2014 11:39
Réputation : 0
Localisation : Créteil (94)

Re: J'ai aussi craqué et je vais avoir besoin de votre aide

Message non lu par bruno » sam. 29 oct. 2016 21:29

Il est pas mal
Perso je monterais encore légèrement le retrait et certainement la température d'extruder.

Côté arduino et Marlin le pb de certaines cartes est effectivement de trouver la bonne version



Avatar du membre
waldi57200
Octocopter
Messages : 754
Enregistré le : jeu. 1 nov. 2012 14:45
Réputation : 0

Re: J'ai aussi craqué et je vais avoir besoin de votre aide

Message non lu par waldi57200 » sam. 29 oct. 2016 22:08

bruno a écrit :Il est pas mal
Perso je monterais encore légèrement le retrait et certainement la température d'extruder.
Je viens de relancer une impression en corrigeant les paramètres que tu dis à voir.

Par contre mon home Z n'est plus bon :x
J'avais un doute mais la fini. En faisant un home les buses touchent le plateau. J'ai pourtant des écrous nylstop sur les vis de réglage du plateau et j'ai sécurisé la vis de butée fin de course Z à la colle à chaud.
J'ai bien mes tiges filetées qui font un léger 8 sur les 10 derniers cm vers le bas. Est ce que ça peut jouer ? J'ai revu l'accouplement est s'est ok.

Merci d'avance ;)

@+


Penguin FPV

FrSky Taranis +

Avatar du membre
waldi57200
Octocopter
Messages : 754
Enregistré le : jeu. 1 nov. 2012 14:45
Réputation : 0

Re: J'ai aussi craqué et je vais avoir besoin de votre aide

Message non lu par waldi57200 » ven. 4 nov. 2016 18:46

Salut à tous

Bon j'ai toujours ce soucis de Z home qui bouge pour le moment je joue avec les offset dans S3D qui lui vient de passer en version 3.1.1 avec language en french SVP [yahoo.gif]

Niveau modif, je vais changer mes ventilos par des plus silencieux et changer les drivers axe x et y avec des tmc2100 qui eux aussi m'apporteront un confort niveau bruit car habitant en appartement pour le moment pas toujours le top en soirée.

Autrement je viens de lancer ma vrai grosse impression en l'occurrence un spot led pour la chambre de mes gamins. J'espère le finir et surtout le réussir ce week-end :)

Je vous ferai un retour.

@+


Penguin FPV

FrSky Taranis +

bruno
Pilote toutes catégories
Messages : 1803
Enregistré le : mar. 15 avr. 2014 11:39
Réputation : 0
Localisation : Créteil (94)

Re: J'ai aussi craqué et je vais avoir besoin de votre aide

Message non lu par bruno » dim. 6 nov. 2016 10:42

Concernant ton Z comment fait tu son réglage avec les endstop ?
Perso voici comment je fait à la main:
Je m'arrange pour arriver au endstop en gardant la possibilité de réglage par les vis de réglage du plateau ensuite j'affine avec les vis du plateau (j'ai aussi de nylstop).
J'ai bien mes tiges filetées qui font un léger 8 sur les 10 derniers cm vers le bas
Tu parles de tiges du Z ?
C'est vrai que les tiges fileté n'ont une super réputation, elles se sont jamais bien droite. Une paire de vis trapézoïdale serait mieux. Mais ceci vas pas jouer sur le décalage du Z.

Ton Pb se trouve ailleurs, les ressorts sont-ils bien en appuis sur le plateau, font-ils bien le travailler demander (pousser le plateau en butté ?). Je suppose que ta femme doit avoir des pinces à linge ... vas faire une petit tour du coté du fil à linge :155: et sans rien dire ... pique lui en 4.
Mais attention :92: :85: te fait pas choppé :mdr1:



Avatar du membre
waldi57200
Octocopter
Messages : 754
Enregistré le : jeu. 1 nov. 2012 14:45
Réputation : 0

Re: J'ai aussi craqué et je vais avoir besoin de votre aide

Message non lu par waldi57200 » dim. 6 nov. 2016 22:02

bruno a écrit :Concernant ton Z comment fait tu son réglage avec les endstop ?
Perso voici comment je fait à la main:
Je m'arrange pour arriver au endstop en gardant la possibilité de réglage par les vis de réglage du plateau ensuite j'affine avec les vis du plateau (j'ai aussi de nylstop).
ben j'ai réglé la vis par rapport au plateau pour que quand l'endstop est activé il y ai juste contact avec le plateau puis j'ai affiné avec chaque vis au 4 coins du plateau
J'ai bien mes tiges filetées qui font un léger 8 sur les 10 derniers cm vers le bas
Tu parles de tiges du Z ? oui
C'est vrai que les tiges fileté n'ont une super réputation, elles se sont jamais bien droite. Une paire de vis trapézoïdale serait mieux. Mais ceci vas pas jouer sur le décalage du Z. Vis trapézoïdale ? Il faut ensuite règle le pas de nouveau ?

Ton Pb se trouve ailleurs, les ressorts sont-ils bien en appuis sur le plateau, font-ils bien le travailler demander (pousser le plateau en butté ?). Je suppose que ta femme doit avoir des pinces à linge ... vas faire une petit tour du coté du fil à linge :155: et sans rien dire ... pique lui en 4.
Mais attention :92: :85: te fait pas choppé :mdr1:
ben je suppose que les ressorts sont ok vu que quand la buse touche le plateau ce dernier descends.par contre, pour les pinces à linges je ne vois pas que faire. J'ai plus l'impression que s'est les moteurs qui ne tourne pas tout à fait synchro car quand je monte l'axe Z en butée haute avec les cals y a une petite différence par moment que je rectifie de temps à autre.


Penguin FPV

FrSky Taranis +

bruno
Pilote toutes catégories
Messages : 1803
Enregistré le : mar. 15 avr. 2014 11:39
Réputation : 0
Localisation : Créteil (94)

Re: J'ai aussi craqué et je vais avoir besoin de votre aide

Message non lu par bruno » dim. 6 nov. 2016 22:08

quand je monte l'axe Z en butée haute avec les cals y a une petite différence par moment que je rectifie de temps à autre.
Un Pb de blocage de point dure ???



Avatar du membre
waldi57200
Octocopter
Messages : 754
Enregistré le : jeu. 1 nov. 2012 14:45
Réputation : 0

Re: J'ai aussi craqué et je vais avoir besoin de votre aide

Message non lu par waldi57200 » lun. 7 nov. 2016 09:40

bruno a écrit : Un Pb de blocage de point dure ???
Franchement non ?
Je regarderai cela de plus près ce week-end, car je n'aurai pas trop le temps cette semaine mais on ne sait jamais.
En tout cas à part ce petit soucis de Z, elle tourne vraiment bien cette imprimante mais y a encore du boulot pour trouver les réglages parfait niveau impressions.

J'ai bien commencé mon spot led ( mais pas fini) ce week-end en testant la couleur noir de chez Esun. Résultat plutôt pas mal ;)
Me reste la partie avant à imprimer mais je vais d'abord installé la douille pour l'ampoule.

Image
Image

@+


Penguin FPV

FrSky Taranis +

Avatar du membre
waldi57200
Octocopter
Messages : 754
Enregistré le : jeu. 1 nov. 2012 14:45
Réputation : 0

Re: J'ai aussi craqué et je vais avoir besoin de votre aide

Message non lu par waldi57200 » ven. 25 nov. 2016 11:09

Salut :hello:

Bon j'ai toujours pas réussi à finir mon spot car j'ai un peu décroché ces derniers temps ( recherche immobilière) .

J'ai par contre changé les roulement à bille du plateau chauffant par des compatible IGUS apparement s'est pas mal donc à voir à l'utilisation.

J'ai également commandé du filament PLA 1,75 colorfabb blanc et là mes impressions sont vraiment dégueux (sous extrusion par moment, rendu pas propres) donc ou mes paramètres sont à revoir ou .... J'ai bien joué sur la température en montant de 5°c jusqu'à 205 en étant parti à 185°C.
Je vais me pencher prochainement nouveau dessus.

Il me faut aussi installer mes nouveaux stepper TCM 2100 pour voir ce que çà donne mais va falloir buché un peu avant pour voir les réglages par la suite.

Donc y'a encore du taf, faut qu'elle soit rady avant que je trouve mon nouvel atelier -y-

@+

Christian


Penguin FPV

FrSky Taranis +

Répondre

Retourner vers « Imprimantes 3D »