Page 1 sur 1

[RESOLU]Probleme Décollage Quad FPV: Twiching, cause:F405 AIO

Posté : sam. 23 déc. 2017 17:36
par Feellthe
Bonjour à tous !

voilà j'ai un problème depuis maintenant 2 semaines : je n'arrive pas à faire décoller mon quad correctement.
voici ma config:

Chassis: Armattan chameleon
Moteurs: EMAX 2306 2750kv
Camera: EAchine okkan
FC: MATEK F405AIO
VTX: Tramp HV
ESC: Racerstar 40A
Helices: king kong 5x5x3


j'ai réalisé 3 vidéos pour illustrer le problème :

https://drive.google.com/file/d/1CGKpcF ... sp=sharing
https://drive.google.com/file/d/1xdYll9 ... sp=sharing
https://www.youtube.com/watch?v=MhkED58 ... e=youtu.be

Aussi, j'a fais les 2 premieres vidéo (en exterieur) APRES la video montrant le PC, Du coup apres la premiere viéo j'avais essayé de modifier ça:

Gyro sampling 32khz mod = 0
gyro freq = 8khz
pid loop freq = 8khz

ce qui avait stabilisé les régimes moteurs, mais comme ont le voit dans les vidéos le quad ne vole pas mieux.

Et j'ai essayé de flasher mes ESC en version supérieure mais toujours pareil.

Voilà si quelqu'un à une solution à essayer je suis preneur.

\/ \/ \/ \/ \/ UPDATE \/ \/ \/ \/ \/

Voici ce que j'ai fait qui n'a pas fait disparaître le défaut :

-Changer les fréquences de Gyro Update et PID Loop
-Changer l'orientation de la FC (de 180° sur le yaw)
-Changer les PID
-Changer de protocole ESC


Voici ce que j'ai fait pour faire disparaître le défaut (toutes combinés) :

-Ajouter les condensateurs fournit dans le sachet : 1 sur chaques sorties moteurs.
-Ajouter la plaque au dessus de la FC (fournit dans le sachet) pour ma part je vais la remplacer par le RunCam SPlit.
-Ajouter les entretoises "Soft Mount" fournit dans le sachet

Enfaite ce défaut est très connu sur les F405 AIO !

Re: Probleme Décollage Quad FPV

Posté : sam. 23 déc. 2017 18:28
par Papi78
Hello
Tu devrais trouver la solution à ton pb ici : https://www.multi-rotor-fans-club.com/v ... 40&t=16613

Re: Probleme Décollage Quad FPV

Posté : sam. 23 déc. 2017 18:36
par Feellthe
Bonjour,

merci pour ta réponse !

en effet je vient juste de le lire et je voit pas plus ce qui pourrais causer le problème. Je trouve le son assez particulier dans la vidéo 1.


je sais pas ce que ça vaut mais je vais essayer de flasher ma FC si jamais.

Re: Probleme Décollage Quad FPV

Posté : sam. 23 déc. 2017 19:02
par Papi78
Tu as bien vérifié dans bétaflight, sans hélices, et en démarrant les moteurs un par un avec les curseurs que les n° moteurs correspondent bien?
Le bruit des moteurs est correct quand tu les démarres un par un?
Les vis des moteurs ne touchent pas les bobinages ( vis parfois trop longues) ?

Re: Probleme Décollage Quad FPV

Posté : sam. 23 déc. 2017 19:38
par Feellthe
Bonsoir,

"Tu as bien vérifié dans bétaflight, sans hélices, et en démarrant les moteurs un par un avec les curseurs que les n° moteurs correspondent bien? "
-Oui

"Le bruit des moteurs est correct quand tu les démarres un par un?"

-Sans hélice oui.

"Les vis des moteurs ne touchent pas les bobinages ( vis parfois trop longues) ?"

-Avant de fixer les protection TPU j'avais essayé des vis qui enfaîte était trop longues ça a peut être touché sur le moment mais j'ai pas serré la vis et
je n'ai pas fait de vol avec ses vis là.

Re: Probleme Décollage Quad FPV

Posté : dim. 24 déc. 2017 16:20
par mrnene
Salut P ;)
Si tu as flashé ta FC, as tu pensé aux 270° de décalage de l'orientation de la FC.

Re: Probleme Décollage Quad FPV

Posté : dim. 31 déc. 2017 01:17
par Feellthe
Bonjour !

tient je savais bien que tu verrais mon post ! ^^

alors une petite mise à jour du coup (je met à jour le premier message aussi)

-J'ai essayé de retourner la FC (c'est a dire de la positionner dans le bon sens) : Toujour le meme défaut.

cet après midi j'ai changé de FC et PDB (j'avais pas la meme en double donc j'ai pris sur un ancien setup et ça marche !

donc les ESC et moteurs sont exclu !

Voilà si maintenant vous voulez plus d'info sur les paramètres etc, je suis dispo, moi je pense me commander une 2 eme FC (même si c'est logiciel ça vaut le coup d'en avoir 1 en secours)

Bon mon problème n'est pas résolut mais je peut quand meme voler !

Re: Probleme Décollage Quad FPV

Posté : lun. 1 janv. 2018 17:06
par mrnene
Je voulais parler du réglage d'orientation dans betaflight, avec cette fc il faut avoir 270° comme réglage, mais tu as dû y penser déjà.
Et puis tien, bonne année à tout le monde :)

Re: Probleme Décollage Quad FPV

Posté : ven. 5 janv. 2018 21:11
par Feellthe
Bonjour !

Alors voici quelques mises à jour concernant le problème, tout d'abord j'ai décidé de ne PAS acheter une deuxième fois cette carte car j'ai découvert qu'elle était source de défaut.

Enfaîte ce défaut est très connu, surtout sur cette carte, en anglais ça s'appel le "TWICHING".

voici une vidéo que j'ai trouvé qui montre le problème que j'ai :

https://www.youtube.com/watch?v=hD-IbGMgEwo

c'est affolant parce que le son est vraiment pareil, un régime moteur qui démarre nickel et après au bout de 30-50%, c'est la merde !


Ici ont retrouve un forum qui explique comment régler le problème :

https://github.com/betaflight/betaflight/issues/3912

j'essaye ça demain et vous dit.

Re: Probleme Décollage Quad FPV

Posté : sam. 6 janv. 2018 19:50
par Feellthe
Bonjour,

trouvé !!!

alors pour résoudre le problème j'ai :

-ajouté les 4 condensateurs livrés avec la FC (1 sur chaque entrées ESC)
-Ajouté la plaque au dessus de la FC (qui sera remplacé par la runcam split)

Du coup tout fonctionne nickel, j'ai toujours un peu de vibrations à full throttle mais je vais régler ça avec les PID (pour le moment stock PID)

vidéo de vol (désolé mais voler à une main c'est chaud) :

https://drive.google.com/open?id=14YbNu ... 5ivR0OKYU5

Cordialement,

Pierre SEGURA

Re: [RESOLU]Probleme Décollage Quad FPV: Twiching, cause:F405 AIO

Posté : mar. 9 janv. 2018 14:38
par mrnene
Les F4 n'aiment pas du tout les vibrations, ça fait de drôle de choses :)
Pour les vibrations avec gaz à fond, il faut augmenter le TPA.

Re: [RESOLU]Probleme Décollage Quad FPV: Twiching, cause:F405 AIO

Posté : mar. 9 janv. 2018 17:49
par Papi78
hello
Tu as conservé les 180° pour l'orientation de la carte ou bien c'était inutile?

Re: [RESOLU]Probleme Décollage Quad FPV: Twiching, cause:F405 AIO

Posté : mar. 9 janv. 2018 18:15
par Feellthe
Hum je te dit ça à partir du 22 Janvier, je suis en formation et ne suis pas chez moi.

ce qui est sur c'est que j'ai mis la carte dans le bon sens donc je dirais que non :

sur le yaw j'ai 270° (à confirmer le 22 janvier 2018)

Re: [RESOLU]Probleme Décollage Quad FPV: Twiching, cause:F405 AIO

Posté : mar. 9 janv. 2018 19:09
par Papi78
En fait j'essaie de comprendre la cause précise du pb pour éventuellement mettre à jour mon topic ;-)
J'ai jeté un œil sur la vidéo où tu expliques les réglages devant le PC et si mes yeux sont encore bons j'ai vu que le Yaw était paramétré à 90. Hors, si j'en juge par la photo vue chez BG: https://www.banggood.com/Matek-Systems- ... 65338.html , quand la flèche est vers l'avant l'USB se retrouve à gauche, donc à l'opposé de la tienne dans la vidéo!
Ce qui voudrait dire que le bon paramètre est 180, mais dans ce cas pkoi le quad réponds bien, avant/arrière, gauche/droite, sur l'écran !!!!!
Et c'est encore plus incompréhensible que ça puisse fonctionner avec 270 8|

Re: [RESOLU]Probleme Décollage Quad FPV: Twiching, cause:F405 AIO

Posté : mer. 10 janv. 2018 16:04
par mrnene
Il faut entrer une valeur de 270°, j’ignore pourquoi :|
C'est le réglage normal, je sais c'est bizarre riencompris

Re: [RESOLU]Probleme Décollage Quad FPV: Twiching, cause:F405 AIO

Posté : mer. 10 janv. 2018 16:52
par Papi78
Oki, mais avec la carte dans quelle position? USB à droite ou à gauche?
Visiblement telle qu'il l'a mise vu que maintenant ça marche, mais y'a un bug quelque part!

Re: [RESOLU]Probleme Décollage Quad FPV: Twiching, cause:F405 AIO

Posté : mer. 10 janv. 2018 17:03
par mrnene
Flèche vers l'avant usb à gauche

Re: [RESOLU]Probleme Décollage Quad FPV: Twiching, cause:F405 AIO

Posté : mer. 10 janv. 2018 17:56
par Papi78
Ben sur sa vidéo c'est flèche vers l'arrière, USB à droite :pendu:
C'est peut-être pour ça que ça fonctionne avec 90°?